请老师帮忙写一个选股公式

admin 28 2024-03-17 07:06:53

选股公式入门书、写选股公式教程、选股公式成功率测试、写选股公式视频、选股公式怎么写以及指标怎么写_技术互助问答论坛 股票软件 指标公式技术 理想股票技术论坛

DRAWGBK(C>O,RGB(60,0,0),RGB(0,0,0),1,2,1);DRAWTEXT_FIX(1,0.88,5,0,''),COLORRED;HH:= (20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+ 14*REF(...指标编写_技术互助问答论坛股票软件指标公式技术

DRAWGBK(C>O,RGB(60,0,0),RGB(0,0,0),1,2,1);

DRAWTEXT_FIX(1,0.88,5,0,''),彩色;

HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H, 5)+14*参考(H,6)

+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF( H,12)

+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF( H,18)+

REF(H,20))/210,颜色蓝色,线厚1;

LL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L, 5)+14*参考(L,6)

+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF( L,12)

+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(左,18)+

REF(L,20))/210,颜色蓝色,线厚1;

D90H:=EMA(HH,90),彩色,线厚1;

D90L:=EMA(LL,90),彩色,线厚1;

DGH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H, 5)+14*参考(H,6)

+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF( H,12)

+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF( H,18)+

REF(H,20))/210,颜色蓝色,LINETHICK1;DDL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16 *REF(L,4)+15*REF(L,5)+14*REF(L,6)

+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF( L,12)

+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(左,18)+

REF(L,20))/210,颜色蓝色,线厚1;

D90C:=D90H-D90L;D90D:=D90H+D90C*2,彩色,线厚1;

D90T:=D90L-D90C*2,彩色,线厚1;

G0:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK1,COLORWHITE;

D0:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK1,COLORWHITE;

DTD:=D0>=D90T 且 G0>=D90D;

KTD:=G0=REF(C,1),DDX,-DDX/100),2,1);

V5:=SMA(V2*240/FROMOPEN*0.9,5,1);

V10:=SMA(V5,5,1);

V20:=SMA(V10,5,1);

TT:=(V2*1.01-REF(V2,1));

TT2:=(REF(V2*1.01,1)-REF(V2,2));

YY:=TT>3*ABS(TT2);

TT1:=EMA(V2,15);

BBI:=(MA(收盘,3)+MA(收盘,6)+MA(收盘,12)+MA(收盘,24))/4;

N:=10;

P:=3;

UPR:=BBI+P*STD(BBI,N);

DWN:=BBI-P*STD(BBI,N);

XF:=L开度值:=ZD1-ZD2;

强区:EVERY(开盘值>REF(开盘值,1),5);

DRAWBAND(强区,120,10,RGB(36,136,36));

X_1:=打开>关闭;

X_2:=最后(X_1,4,3);

X_3:=REF(CLOSEX_4:=REF(收盘,1)X_5:=REF(开盘/收盘,1)X_6:=(高+低+收盘)/3;

X_7:=(X_6-MA(X_6,14))/(0.013*AVEDEV(X_6,14));

X_8:=X_7>(-232);

X_9:=X_7>REF(X_7,1)*1.06;

X_10:=关闭/参考(关闭,1)>1.005;

X_11:=VOLX_12:=关闭>参考(打开,1)*0.998;

X_13:=REF(开/关,1)X_14:=REF(音量,1)X_15:=REF(低,2)>REF(低,3)*0.99;

X_16:=HIGHX_17:=MA(收盘价,60)/收盘价>1.035;

X_18:=低>参考(低,2)*0.995;

X_19:=开/关>1.07;

X_20:=计数(X_19,4)=0;

X_21:=开盘>参考(关盘,3)*0.998;

X_22:=高/低X_23:=REF(高,1)>REF(低,2);

X_24:=打开>参考(关闭,1);

X_25:=COUNT(X_24,8)>=1;

X_26:=REF(VOL1.015 且收盘>REF(高,1);

追踪:X_2 AND X_3 AND X_4 AND X_5 AND X_8 AND X_10 AND X_11 AND X_12 AND X_12 AND X_14 AND X_15 AND X_16 AND X_9 AND X_17 AND

粘线(追求,900.5,0,3,0),彩色;

STICKLINE(追击,900.5,0,2.8,0),COLOR6600FF;

STICKLINE(追踪,900.5,0,2.1,0),COLORBB00FF;

STICKLINE(追求,900.5,0,1.8,0),洋红色;

STICKLINE(追踪,900.5,0,1.6,0),COLORFF33FF;

STICKLINE(追踪,900.5,0,0.8,0),COLORFF66FF;

STICKLINE(追求,900.5,0,0.4,0),COLORFF99FF;DRAWTEXT_FIX(1,0.01,0.01,0,'.'),;KX:='CHANLUN@KXIAN';

KXG:='CHANLUN@KXG';

KXD:='CHANLUN@KXD';

KXFX:='CHANLUN@KXFX';

笔:='CHANLUN@BI';

画笔周期:='CHANLUN@BILAST',LINETHICK0,COLORFF00FF;

BILAST:='CHANLUN@BILAST';{笔周期};

节:='CHANLUN@DUAN';

段周期:='CHANLUN@DUANLAST', LINETHICK0, COLORFFFFFF;

DUANLAST:='CHANLUN@DUANLAST'; {段周期};

中心:='CHANLUN@ZS';

ZSZG:='CHANLUN@ZSZG';

ZSZD:='CHANLUN@ZSZD';

ZSGG:='CHANLUN@ZSGG';

ZSDD:='CHANLUN@ZSDD';

ZSZZ:='CHANLUN@ZSZZ';

ZSKS:='CHANLUN@ZSKSLAST';

ZSJS:='CHANLUN@ZSJSLAST';

BIFX:=-REF(笔,BILAST);

DUANFX:=-REF(段,DUANLAST);

KXQJ:='CHANLUN@KXQJ';

{绘图中心BEGIN} {绘制为背景}

STICKLINE(ZSZG>ZSZD 且 DUANFX=1, ZSZG, ZSZD, 10, 8),COLOR8E236B;

STICKLINE(ZSZG>ZSZD 且 DUANFX=-1, ZSZG, ZSZD, 10, 8), COLOR007700;

{中央震动监视器}

画线(ZSKS=1, ZSZZ, ZSJS=1, ZSZZ, 0), COLORFFFFFF;

{图片中心END}

{顶部和底部分开}

{STICKLINE(KX>0, KXG, KXD, 5, 1),COLOR007700,LINETHICK2;}

粘线(KX{行程}

STICKLINE(笔=1, KXG, KXD, 5, 1), COLORGREEN, LINETHICK2;

STICKLINE(笔=-1, KXG, KXD, 5, 1), 彩色, LINETHICK2;

STICKLINE(线段=1, KXG, KXD, 5, 0), COLOR007700, LINETHICK2;

STICKLINE(线段=-1, KXG, KXD, 5, 0), COLOR0000CC, LINETHICK2;

{绘制K线END}

{刷段}

DRAWLINE(画笔=1,H,画笔=-1,L,0),COLORBLUE,LINETHICK2;

DRAWLINE(画笔=-1,L,画笔=1,H,0),COLORFF00FF,LINETHICK2;

DRAWLINE(线段=1,H,线段=-1,L,0),COLOR007700, LINETHICK2;

DRAWLINE(线段=-1,L,线段=1,H,0),COLORRED, LINETHICK2;

{笔高低点循环强度技巧}

DRAWTEXT(笔=1, H*1.038,H),彩色;

DRAWTEXT(笔=-1, L*0.96, L),COLORFFFFFF;

VAR3:=LLV(H,240);

VAR4:=100*(C-VAR3)/VAR3;

VAR5:=(C-LLV(L,528))/(HHV(H,528)-LLV(L,528))*100;

VAR6:=(C-LLV(C,530))/(HHV(C,530)-LLV(C,530))*100;

VAR7:=0;

VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;

VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;

VAR10:=IF(槽线(3,16,1)=0 且 H>L+0.04,4,0);

VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)REF(ZIG(3,22),1) AND REF(ZIG(3) ,22),1)REF(ZIG(3,51),1) 和 REF(ZIG(3,51),1)REF(ZIG(3,72),1) 和 REF(ZIG(3,72), 1)0 或吸2>0;

ZQS:=CURRBARSCOUNTO),(APP)*(HL),IF((LSF:=IF((H>O),0-(APP)*(H-C+OL),IF((LStock 能量:= MA (ZL+SF,2);

库存平均值:=MA(ZL+SF,5);

{}

{}

PL5:=ZIG(3,5);

EN1:=PL5>REF(PL5,1) AND REF(PL5,1)REF(PL10,1) AND REF(PL10,1)REF(PL20,1) AND REF(PL20,1)REF(PL5,1) );

强2:=BARSLAST(PL10 弱2:=BARSLAST(PL10>REF(PL10,1));

强3:=BARSLAST(PL20 弱3:=BARSLAST(PL20>REF(PL20,1));

ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,更强2),0);

ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,更强2),0);

DTJZ5:=IF(PL10DTJD5:=IF(PL10ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,强3),0);

ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,强3),0);

DTJZ10:=IF(PL20DTJD10:=IF(PL20

DRAWTEXT(EN2 AND DTJZ10=1,L*0.96,'2级购买'),COLORFFFFFF;

DRAWTEXT(EN3 AND ZTJZ10=1,L*0.95,'一次购买'),COLORFF00FF;---------------------------- --- ---------------------------------------------------------- ---精选,Suck,(如果有Suck 1和Suck 2则分别选择)一买二类买四选股公式,谢谢!

此帖寻求各位老师的解答

上一篇:科技板块领涨A股市场热点频出
下一篇:一天之内,两家公司撤回主板IPO!
相关文章

 发表评论

暂时没有评论,来抢沙发吧~

返回顶部小火箭